Neueste Nachrichten (in Englisch): (am laden..)
shoptrader

Bei PayPal Zahlung Bestellung nur im admin

5 Beiträge in diesem Thema

Liebe Mitshopper

in meinem "alten" Shop 2.3.4 (responsive) passiert seit längerer Zeit folgendes, dies auch nach Installation des neuesten PayPal addons:

alles i.O. bei Zahlungsart Banküberweisung; Bestellung ist im admin ersichtlich, OsC sendet mir an die Shop-e-mail-Adresse die Bestellung und diese lässt sich via Verbindungssoftware (connector) runterladen in die externe WaWi-/Rechnungssoftware zur Erstellung des Lieferscheins/Rechnung.

 

Bei Zahlungsart PayPal ist die Bestellung ebenfalls im admin ersichtlich, OsC sendet mir an die Shop-e-mail-Adresse jedoch nur eine Debug e-mail mit ein paar wenigen Zahlen/Buchstaben drin (ohne Bestellungsinhalt und Kundenadresse);

an die PayPal-Zahladresse (andere e-mail-Adresse) erhalte ich von PayPal die Anzeige des Zahlungseingangs;

Die Bestellung lässt sich via Verbindungssoftware (connector) NICHT runterladen in die externe WaWi-/Rechnungssoftware

Was muss ich tun, damit mir OsC die Bestellung korrekt sendet an die Shop-e-mail Adresse ?

Danke für jeden kleinen Hinweis!

Gruss Walter

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Diese Frage betrifft Deine WAWI Software, somit solltest Du bei denen im Support nachfragen.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo mcmannehan

Hier ein Link zum Connector: http://vorlagen.fakturama.info/webshops/oscommerce/

Wie bereits von mir erwähnt, funktioniert ja der Connector bei Zahlungsart Banküberweisung, also ohne PayPal.

Ich glaube (nicht wisse) dass es daher eher was zu tun hat mit der Rückmeldung vom Shop (osCommerce) bei Zahlungsart PayPal; ich krieg da nur die Debug-e-mail, hier ein aktuelles Inhalts-Beispiel einer solchen Debug e-mail:

Betreff: PayPal Standard Debug e-mail

$HTTP_GET_VARS:

Array
(
    [amt] => 55.55
    [cc] => EUR
    [cm] => 301
    [st] => Completed
    [tx] => 3CK04512G4088202S
)

Hoffe du kannst was interpretieren daraus

Gruss Walter

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hat mir keine Ruhe gelassen, da mein Shop ohne PayPal weitgehend nutzlos ist.

Dachte, am WaWi Connector kann es kaum liegen, da statische Datei, dies hat sich nun bestätigt.

Habe nach durchforsten auch des englischsprachigen osC Forums festgestellt, dass viele Shopbetreiber genau das gleiche Problem haben mit PayPal Standard und offensichtlich seit 2014 keine Lösung vorhanden ist,

zumindest keine, die ich umsetzen kann, ohne den halben Shop umzucoden (was bei meinem Wissen eher schlecht rauskommen würde).

Habe nun ganz einfach im Admin unter modules/payment das normale PayPal EXPRESS installiert, die API Daten aus dem PayPal account reinkopiert.

Funktioniert, ich krieg die tadellose Bestellungs-e-mail und kann diese mit dem Connector runterladen

Vielleicht hilft dies Anderen auch

Gruss Walter

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Paypal Standard benutzt seine eigene Checkout Prozess. Paypal express nicht, deshalb funktioniert es.

Bei mir fumktioniert Paypal Standard einwandfrei, ist irgendwie seltsam.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an um zu kommentieren

Du musst ein Benutzerkonto haben um einen Kommentar hinterlassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Geht einfach!


Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.


Jetzt anmelden