Neueste Nachrichten (in Englisch): (am laden..)

shoptrader

Members
  • Gesamte Inhalte

    106
  • Benutzer seit

  • Letzter Besuch

Ansehen in der Community

2 Neutral

1 folgt dem Benutzer

Über shoptrader

Profile Information

  • Gender
    Male
  • Ihr Name
    B.W.M.
  • Location
    CH
  1. SSL Einstellungen

    Hallo mcmannehan Wahrscheinlich sind die Meisten hier im Forum nicht so gut wie du (heuchel, hust....); ich selber bezeichne mich da gerne als Viertelwissender. Und den Viertel, den ich weiss, habe ich fast ausschliesslich von verschiedensten, ausgesprochen hilfreichen Forumsmitgliedern hier gelernt, die sich nie zu schade sind, auch sinnlos scheinende Fragen zu beantworten. Von wegen kein Lerneffekt hier im Forum muss ich dir also heftigst widersprechen, da liegst du meiner Meinung nach komplett falsch. Und nicht zuletzt habe ich ja einen funktionierenden zweiten Shop, mit Viertelwissen aufgebaut und funktioniert. Wenn Andere hier im Forum nach jeder zweiten "dummen" Frage nach Bezahlung verlangen würden, dann gäbe es hier wahrscheinlich ein paar sehr reiche Leute. Diese reichen Leute gibt es tatsächlich hier, reich an Wissen, das sie unvoreingenommen weitergeben; auch an "Dummies" wie mich. Gruss Walter
  2. SSL Einstellungen

    Hallo mcmannehan Stecke grad fest. Mein HP hat den server gewechselt, fast gleichzeitig hatte ich das franz. Sprachpaket installiert, das war vielleicht etwas suboptimal. Nun krieg ich database.php nicht hin. Bei Aufruf der Seite zeigt sich das hier: Warning: mysqli_connect(): (HY000/1045): Access denied for user 'username'@'server' (using password: YES) in /home/meinshop/public_html/meinshop/admin/includes/functions/database.php on line 20 Unable to connect to database server! line 20 (nur diese habe ich geändert) in database.php sieht so aus: Released under the GNU General Public License */ function tep_db_connect($server = DB_SERVER, $username = DB_SERVER_USERNAME, $password = DB_SERVER_PASSWORD, $database = DB_DATABASE, $link = 'db_link') { global $$link; if (USE_PCONNECT == 'true') { $server = 'p:' . $server; } $$link = mysqli_connect('123.456.7.89', 'username', 'password', 'databasename'); if ( !mysqli_connect_errno() ) { mysqli_set_charset($$link, 'utf8'); } return $$link; Was habe ich da falsch gemacht? Danke für deinen Tipp. Anmerkung: admin ist via HP Konsole geschützt (anstelle von htaccess) Gruss Walter
  3. Hat mir keine Ruhe gelassen, da mein Shop ohne PayPal weitgehend nutzlos ist. Dachte, am WaWi Connector kann es kaum liegen, da statische Datei, dies hat sich nun bestätigt. Habe nach durchforsten auch des englischsprachigen osC Forums festgestellt, dass viele Shopbetreiber genau das gleiche Problem haben mit PayPal Standard und offensichtlich seit 2014 keine Lösung vorhanden ist, zumindest keine, die ich umsetzen kann, ohne den halben Shop umzucoden (was bei meinem Wissen eher schlecht rauskommen würde). Habe nun ganz einfach im Admin unter modules/payment das normale PayPal EXPRESS installiert, die API Daten aus dem PayPal account reinkopiert. Funktioniert, ich krieg die tadellose Bestellungs-e-mail und kann diese mit dem Connector runterladen Vielleicht hilft dies Anderen auch Gruss Walter
  4. Hallo mcmannehan Hier ein Link zum Connector: http://vorlagen.fakturama.info/webshops/oscommerce/ Wie bereits von mir erwähnt, funktioniert ja der Connector bei Zahlungsart Banküberweisung, also ohne PayPal. Ich glaube (nicht wisse) dass es daher eher was zu tun hat mit der Rückmeldung vom Shop (osCommerce) bei Zahlungsart PayPal; ich krieg da nur die Debug-e-mail, hier ein aktuelles Inhalts-Beispiel einer solchen Debug e-mail: Betreff: PayPal Standard Debug e-mail $HTTP_GET_VARS: Array ( [amt] => 55.55 [cc] => EUR [cm] => 301 [st] => Completed [tx] => 3CK04512G4088202S ) Hoffe du kannst was interpretieren daraus Gruss Walter
  5. SSL Einstellungen

    Hallo mcmannehan Vielen Dank für deine wertvollen inputs; Sprengstoff für meine verkalkten Synapsen! Ich hatte den Shop gemäss Anleitung installiert (TEIA, "Einrichtung und Betrieb eines Webshops am Beispiel von osCommerce") , bisschen älter schon, aber recht nützlich. SSL kann ich direkt im HP Portal ein- oder ausschalten, ich meinte dass das Zertifikat vom HP mitgeliefert wird (?) Viertelwissender hat nun folgendes gemacht: catalog/admin...... vom server runtergeladen, vom server gelöscht, admin...... (ohne catalog) wieder rauf includes/configure und admin/includes/configure https Einträge geändert und in admin/includes/configure Einträge "catalog" bei Cookie domain entfernt (da nach den anfangs beschriebenen Änderungen kein admin Zugang mehr) Der Shop inklusive admin ist nun auf jede Art und Weise aufrufbar. Einfach nur schön, tolle Arbeit von dir! Für meinen ersten Shop benötigte ich 1,5 Jahre (da null Ahnung), für den zweiten 1,5 Monate und für den hier jetzt 1,5 Wochen Werde für die 30% französisch sprechenden in der Schweiz die Zweitsprache erst mal in englisch lassen Gruss Walter
  6. SSL Einstellungen

    Hallo mcmannehan Danke für dein PM mit dem Angebot. Muss im Moment bei light bleiben, da mein Shop nur hobbymässig am Abend bearbeitet wird, darum ist auch alles Andere zu 100% openSource, alles ist sehr einfach gestrickt. In ein paar wenigen Jährchen kann ich das Geschäftchen dann ausbauen zum Geschäft, muss ja was zu tun haben als Pensionär/Rentner. Dein light Shop ist installiert auf PHP7, ich komme in den admin rein, wunderbar. Ich kann den Shop aufrufen (noch mit Zusatz "catalog") http://meinshop.ch/catalog oder auch https://meinshop.ch/catalog Das funktioniert soweit, es werden jedoch keinerlei Bilder angezeigt, nur der Shopinhalt als tabellenartiger Text. Wahrscheinlich was Klitzekleines, komm aber leider nicht drauf. Kannst du mich da mal anschieben ? Danke und Gruss Walter
  7. Liebe Mitshopper in meinem "alten" Shop 2.3.4 (responsive) passiert seit längerer Zeit folgendes, dies auch nach Installation des neuesten PayPal addons: alles i.O. bei Zahlungsart Banküberweisung; Bestellung ist im admin ersichtlich, OsC sendet mir an die Shop-e-mail-Adresse die Bestellung und diese lässt sich via Verbindungssoftware (connector) runterladen in die externe WaWi-/Rechnungssoftware zur Erstellung des Lieferscheins/Rechnung. Bei Zahlungsart PayPal ist die Bestellung ebenfalls im admin ersichtlich, OsC sendet mir an die Shop-e-mail-Adresse jedoch nur eine Debug e-mail mit ein paar wenigen Zahlen/Buchstaben drin (ohne Bestellungsinhalt und Kundenadresse); an die PayPal-Zahladresse (andere e-mail-Adresse) erhalte ich von PayPal die Anzeige des Zahlungseingangs; Die Bestellung lässt sich via Verbindungssoftware (connector) NICHT runterladen in die externe WaWi-/Rechnungssoftware Was muss ich tun, damit mir OsC die Bestellung korrekt sendet an die Shop-e-mail Adresse ? Danke für jeden kleinen Hinweis! Gruss Walter
  8. Zitat Ingo Malchow 28.04.2017: "Wichtig ist, in der configure.php bei HTTPS_SERVER genau die Domain einzutragen, für die das SSL-Zertifikat ausgegeben wurde. Wenn Ihr ein Zertifikat für "meineseite.de" beantragt habt, MUSS diese hier auch eingetragen sein. "www.meineseite.de" ist nicht das selbe wie "meineseite.de". Bei manchen Zertifikaten schließt jedoch das eine, das andere mit ein. Vorher genau erkundigen und/oder lesen!" Hallo mcmannehan Verspätete Antwort wegen Abwesenheit. Genau das, was Ingo Malchow schreibt, habe ich nicht zu 100% richtig gemacht (ein "s" vergessen und nicht genau die richtige Domainbezeichnung eingetragen). Jetzt funktioniert es wieder, trotzdem vielen Dank für deinen input. P.S. Dein Responsive light-shop ist schon mal auf dem Server; mal sehen wie weit ich komme ohne Hilfe ;-) Gruss Walter
  9. Liebe Gemeinde Benötige dringend einen Suchansatz, steh grad ziemlich auf dem Schlauch: 2.3.4 shop (responsive). Folgendes passiert: Kunde meldet sich an, legt etwas in den Warenkorb, dies wird angezeigt und die url sieht dann so aus: http://www.meinshop.ch/shopping_cart.php Kunde clickt nun "zur Kasse", jetzt wird angezeigt "Ihr Warenkorb ist leer", die url sieht jetzt so aus: https://meinshop.ch/shopping_cart.php Wird nun im (angeblich) leeren Warenkorb der Button "Weiter" geclickt, zeigt die url http://www.meinshop.ch/index.php , oben im Warenkorb wird wieder die Anzahl Artikel angezeigt, dies lässt sich im Kreis immer wieder reproduzieren, aber schlussendlich kommt man nicht zum Bestellungsabschluss. Schon ein grober Suchansatz würde mir enorm helfen, vielen Dank schon mal! Gruss Walter
  10. Hallo mcmannehan Danke für die Antworten. Verstehe ich das richtig: es gibt einen Unterschied zwischen dieser Version hier: https://github.com/mcmannehan/osCommerce-WDW-PV7.0-Pimp-Version-Responsiv und deiner "Pimp Vollversion" ? Und das French full language pack 2.3.4 wird nicht funktionieren? Hinweis: Mein shop ist betont einfach aufgebaut (so, dass ich noch den Überblick habe), PayPal Zahlung und Banküberweisung, fettich. Rechtliche Absicherung ist in CH radikal einfacher als in D, die Abmahn-Mafia hat hier kein Brot. Gruss Walter
  11. Edit zu meinen Fragen (wer lesen kann.....): Downloads gefunden. Funktionieren die Sprachpakete d + f und Harald Ponce Leons PayPal mit deiner Pimp-Version? Gruss Walter
  12. Hallo mcmannehan Bin zufällig über deinen Shop "gestolpert", sieht toll aus! Betreibe seit rund 2 Jahren meinen zweiten Shop, einen 2.3.4 responsive shop (2-sprachig d&f, admin e), den ich mit grosser Hilfe vom Dokta zum laufen gebracht habe, der Shop wird zu 100% mit lizenzfreier Software betrieben Ubuntu & Fakturama. ------------- Nun schaltet mein Hosting Provider PHP5.3 endgültig ab, so dass mein erster Shop zumindest im admin nicht mehr laufen wird. Dieser Shop wird ohnehin für einen anderen Zweck eingesetzt werden, ist also ein Kandidat zum Neu aufsetzen auf PHP7. Fragen zu deiner Pimp-Version: Finde ich dazu passend ein deutsches Sprachpaket? (bei französisch gehe schon mal davon aus, dass ich das selber machen muss(?) Welches PayPal Paket funktioniert damit? Danke für deine Rückmeldung Gruss Walter
  13. Paypal IPN klappt nicht

    Hallo liebe "Leidensgenossen" (tönt ja fast wie Eidgenossen ) Nachdem ich in meinem 2.3.4 shop (bootstrap 2-sprachig d/f) bisher keine Probleme hatte, entdecke ich nun seit ein paar Monaten einige "tote" Bestellungen im admin, bei welchen der Kunde offensichtlich die von euch bereits beschriebenen Probleme mit PayPal hatte. Nach längerer Suche bin ich zum Schluss gekommen, dass mit der PayPal app 4.039 das Problem möglicherweise behoben werden könnte. Möchte nur Punkt 1 (Administration Tool App Setup) der "Legacy Changes" durchführen, da wird folgendes verlangt (Auszug aus der englischsprachige Dokumentation von Harald Ponce de Leon zur PayPal app 4.039): 1. Administration Tool App Setup osCommerce Online Merchant up to v2.3.3.2 (5-Sept-2013) In catalog/admin/includes/column_left.php, add the following to the collection of existing boxes being included: include(DIR_WS_BOXES . 'paypal.php'); Ich mit meinem Viertelwissen weiss nicht richtig, wo genau include(DIR_WS_BOXES . 'paypal.php'); zu platzieren ist. Kann mir da jemand von euch die richtige Zeile in der untenstehenden column_left.php aufzeigen, bitte ? Vielen Dank im Voraus und liebe Grüsse, Walter Hier die aufgeführte column_left.php: <?php /* $Id$ osCommerce, Open Source E-Commerce Solutions http://www.oscommerce.com Copyright (c) 2014 osCommerce Released under the GNU General Public License */ if (tep_session_is_registered('admin')) { $cl_box_groups = array(); if ($dir = @dir(DIR_FS_ADMIN . 'includes/boxes')) { $files = array(); while ($file = $dir->read()) { if (!is_dir($dir->path . '/' . $file)) { if (substr($file, strrpos($file, '.')) == '.php') { $files[] = $file; } } } $dir->close(); natcasesort($files); foreach ( $files as $file ) { if ( file_exists(DIR_FS_ADMIN . 'includes/languages/' . $language . '/modules/boxes/' . $file) ) { include(DIR_FS_ADMIN . 'includes/languages/' . $language . '/modules/boxes/' . $file); } include($dir->path . '/' . $file); } } function tep_sort_admin_boxes($a, $b) { return strcasecmp($a['heading'], $b['heading']); } usort($cl_box_groups, 'tep_sort_admin_boxes'); function tep_sort_admin_boxes_links($a, $b) { return strcasecmp($a['title'], $b['title']); } foreach ( $cl_box_groups as &$group ) { usort($group['apps'], 'tep_sort_admin_boxes_links'); } ?> <div id="adminAppMenu"> <?php foreach ($cl_box_groups as $groups) { echo '<h3><a href="#">' . $groups['heading'] . '</a></h3>' . '<div><ul>'; foreach ($groups['apps'] as $app) { echo '<li><a href="' . $app['link'] . '">' . $app['title'] . '</a></li>'; } echo '</ul></div>'; } ?> </div> <script type="text/javascript"> $('#adminAppMenu').accordion({ heightStyle: 'content', collapsible: true, <?php $counter = 0; foreach ($cl_box_groups as $groups) { foreach ($groups['apps'] as $app) { if ($app['code'] == $PHP_SELF) { break 2; } } $counter++; } echo 'active: ' . (isset($app) && ($app['code'] == $PHP_SELF) ? $counter : 'false'); ?> }); </script> <?php } ?>
  14. Responsive Shop

    Hi Tsimi Vielleicht auch für Andere hilfreich, habe ALLE deine Inputs wie folgt umgesetzt, voll Bingo, funktioniert nun in beiden Sprachen, man kann nun das Datum händisch mit Slash oder Punkt reintippen oder im Datepicker-Feld holen und es erscheint im Konto das Geburtsdatum im gewünschten Format dd/mm/yyyy. Super!, Ganz herzlichen Dank! Gruss Walter In der german.php: define('JQUERY_DATEPICKER_I18N_CODE', '');// leave empty for en_US; see http://jqueryui.com/demos/datepicker/#localization define('JQUERY_DATEPICKER_FORMAT',''); // see http://docs.jquery.com/UI/Datepicker/formatDate In der french.php (in meinem Fall): define('JQUERY_DATEPICKER_I18N_CODE', ''); // leave empty for en_US; see http://jqueryui.com/demos/datepicker/#localization define('JQUERY_DATEPICKER_FORMAT',''); // see http://docs.jquery.com/UI/Datepicker/formatDate ebenso geändert (in german.php und in french.php): //// // Return date in raw format // $date should be in format mm/dd/yyyy // raw date is in format YYYYMMDD, or DDMMYYYY function tep_date_raw($date, $reverse = false) { if ($reverse) { return substr($date, ) . substr($date, ) .substr($date, ); } else { return substr($date, ) . substr($date, ) .substr($date, ); } } Und auch in ext/datepicker/js/bootstrap-datepicker.js this.format = DPGlobal.parseFormat(options.format||this.element.data('date-format')||'');
  15. Responsive Shop

    Datepicker im Responsive Shop: Ein Kunde (etwa der 100ste) hat mich erstmals auf folgendes aufmerksam gemacht: Fehlermeldung. "Ihr Geburtstag muss im folgenden Format angegeben werden: DD/MM/YYYY (z.B. 21/05/1970)" Schreibt man das händisch wie oben in der Fehlermeldung im Format DD/MM/YYYY (ohne Anwahl im Datepicker-Feld), ins Feld Geburtsdatum rein, dann erscheint eben die oben aufgeführte Fehlermeldung. Wählt man die einzelnen Punkte aus im Datepickerfeld, dann geschieht dies in der Reihenfolge Jahr / Monat / Tag, im Feld Geburtsdatum wird es dann aber interessanterweise dargestellt im Format Monat / Tag / Jahr Wie krieg ich den Datepicker zur Reihenfolge Tag / Monat / Jahr mit entsprechender Darstellung im Feld Geburtstag ?? Danke für jeden Tipp Gruss Walter